• RE: KUSB-488B USB to GPIB not recognized by my pc - Keithley 2290-5kV DC power supply

    I'd do that. Thank you.
  • KUSB-488B USB to GPIB not recognized by my pc - Keithley 2290-5kV DC power supply

    Please I need some help in troubleshooting the issue with my KUSB-488B USB to GPIB converter as I have tried everything, I know to get it to work again but I've been unsuccessful at that. The hard drive has been functioning well until yesterday when I tried running my usual experiments while outputting the required high voltage (Currently using the Keithley 2290-5kV DC power supply).  I use NI LabVIEW to control the output voltage remotely. Upon clicking the 'output' button in the LabVIEW voltage generator code, I heard an unusual sound that sounded like sparks which also interfered with the screen/code in a way - It flickered while the spark sound was on. Upon noticing this, I quickly stopped outputting the voltage.  After that, I tried reconnecting the code to the voltage generator, but it failed to connect to the Keithley voltage generator and gave a 'session connect failed, check connections' message. Upon seeing this message, I tried a couple of things listed below.
    1. Disconnecting and reconnecting the USB port using the initial port and a different port and then restarting the system, but the system kept prompting that the USB device had malfunctioned and that windows did not recognise it.  
    2. I then disconnected and reconnected the GPIB from the rear of the voltage generator but that also did not work. 
    3.  I also tried uninstalling and re-installing the KUSB 488 driver (version 3.13.2) and then restarting the system to see if that would solve the problem, but it was futile. 
    4. Since the computer could not recognize the 488B USB to GPIB converter, I also tried adding and installing it manually. It showed that the installation was successful, but the computer noted it as an unknown device. 
    5. Upon checking the NI Visa Interactive control, I found that the usual 'GPIB Instrument Resource' was not present. I only saw GPIB Miscellaneous resource, which had GPIB0: INFC beneath it. 
    6. The final step I did was to check the Keithley GPIB configuration utility and found that beneath GPIB0 were two devices named I(PA:255, SA:255) instead of the Keithley instrument.
    Since all my troubleshooting efforts were futile, I'm unsure of the next step(s) and was hoping to get some help here. I however suspect that I might need to get a new KUSB-488B USB to GPIB converter. Would you please let me know if there are other things I need to try or if getting a new KUSB-488B USB to GPIB converter is my only option in this case. 

    Thank you.